1. Here's a thread that needs an answer: Business Projects question

Offline address book (not) connecting to Microsoft Exchange

Discussion in 'Exchange Server Questions' started by tholyoak, May 21, 2010.

  1. tholyoak

    tholyoak

    Guest
    We have set up an Exchange 2010 server and are almost ready to put our employees on it. We are not upgrading from another version of Exchange - we have never used it before. I have set the mailbox database to use the default offline address book. However, when we try to do a send/receive from Outlook 2007 (or even Outlook 2010), it says " Offline address book connecting to Microsoft Exchange" but goes no further. We left it running overnight and it was still sitting there with the same message this morning. Since everyone will be using Outlook 2007 or 2010, I just have it set for web-based distribution, and we have no plans to use public folders. We are just using the self-signed SSL certificate on the Exchange server, so I'm wondering if there is an issue with that, but I understand (possibly incorrectly?) that it doesn't necessarily use SSL for web-based distribution unless you change the settings in IIS to force it to. I've tried manually going under Send/Receive on the menu and downloading the address book and have the same problem.
  2. Laeeq Qazi

    Laeeq Qazi

    Guest
    We have set up an Exchange 2010 server and are almost ready to put our employees on it. We are not upgrading from another version of Exchange - we have never used it before. I have set the mailbox database to use the default offline address book. However, when we try to do a send/receive from Outlook 2007 (or even Outlook 2010), it says " Offline address book connecting to Microsoft Exchange" but goes no further. We left it running overnight and it was still sitting there with the same message this morning. Since everyone will be using Outlook 2007 or 2010, I just have it set for web-based distribution, and we have no plans to use public folders. We are just using the self-signed SSL certificate on the Exchange server, so I'm wondering if there is an issue with that, but I understand (possibly incorrectly?) that it doesn't necessarily use SSL for web-based distribution unless you change the settings in IIS to force it to. I've tried manually going under Send/Receive on the menu and downloading the address book and have the same problem.

    1. Did u check this for a domain joined outlook client or outside your domain (or an internet connection)?

    2. Have u configured OWA redirection?

    3. On your CAS server goto C:\Program Files\Microsoft\Exchange Server\Client Access\OAB" folder and see if web.config exists there?

    4. If u r testing from internet then Have u configured different Exchange web services and OAB external URLs?

    by default Outlook Anywhere doesnt work with self signed SSL until u do some extra work to import self signed certificate on your outlook machine root CA.

    Regards,

    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
  3. Fazal Muhammad Khan_

    Fazal Muhammad Khan_

    Guest
  4. tholyoak

    tholyoak

    Guest
    1. Did u check this for a domain joined outlook client or outside your domain (or an internet connection)?

    2. Have u configured OWA redirection?

    3. On your CAS server goto C:\Program Files\Microsoft\Exchange Server\Client Access\OAB" folder and see if web.config exists there?

    4. If u r testing from internet then Have u configured different Exchange web services and OAB external URLs?

    1. The clients I have tested on are on the same LAN as the Exchange server, connected to the same domain.

    2. Yes. It works fine.

    3. Yes, web.config exists there. But I can't figure out how to look and see what's inside it.

    4. I do have different internal and external URLs configured, and OWA works internally and externally. But I am only trying to download the OAB internally.
  5. tholyoak

    tholyoak

    Guest
    Try running Exchange Best Practices Analyzer and EXTRA.

    Also have a look at

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/548f2ecc-faae-4744-8b33-7de536196d7d

    Hope this Solves your problem

    Regards

    Fazal Muhammad Khan | MCT, MCSE, MCSA, MCTS | Infrastructure Consultant, Technology Services | CDC Pakistan Ltd. | https://fazalmkhan.spaces.live.com | OFFICE: +92 21 111 111 500 Ext: 1402 | +5 GMT

    I'm not sure what EXTRA is, but I'm running the Exchange Best Practices Analyzer. However, it sort of looks like it was written for Exchange 2007 rather than 2010?

    The thread you pointed out seems to be about a similar problem on 2007 - hopefully the information is also helpful for 2010. But I'm not quite sure I understand what they did to the web.config file to make it work.
  6. Laeeq Qazi

    Laeeq Qazi

    Guest
    Ok.

    On your CAS server goto C:\Program Files\Microsoft\Exchange Server\Client Access\OAB" folder and and right-click web.config and open properties->Security tab and give Authenticated Users both the read and read-and-execute permissions. Run a iisreset /noforce on the CAS server and then check.

    One other important thing to check is see that your OAB virtual directory has no redirection set.

    Regards,

    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
  7. tholyoak

    tholyoak

    Guest
    Thanks! Authenticated Users didn't even have permissions on that file, so I added it, and that did the trick!

Share This Page