1. Here's a thread that needs an answer: Importing Opportunities in to BCM 2013

Exchange 2010 Receives But Does Not Send Email To Internet

Discussion in 'Exchange Server Questions' started by Ifeatu Osegbo, Jul 2, 2010.

  1. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    I have set up Exchange 2010.

    I have installed everything and am able to receive emails from external world but I cannot send to them, eg I cannot send to Yahoo.

    I have used the Exchange Test Connectivity here: https://testexchangeconnectivity.com and everything worked fine.

    I have also configured the Send Connectors and everything seems fine, yet, I cannot send emails to external addresses.

    Internally, everything works fine. Please help

    Ifeatu!
     
  2. TWHarrington

    TWHarrington

    Guest
    Are you getting NDR's? Emails in the queue? Is Exchange HUB the last hop to the Internet or is it passing through a smarthost/Edge server? Do you have port 25 outbound open on your firewall?
     
  3. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Yes, I have the following:

    451 4.4.0 Primary target IP address responded with: " 421 4.2.1 Unable to connect." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

    The Exchange is Hub, no Edge at all, no smart host at all.. Port 25 is open and I confirmed with telnet.

    Thanks for your prompt response.
     
  4. TWHarrington

    TWHarrington

    Guest
    Is there coexitence with older version of Exchange? How many Send Connectors have been created? How many HUB servers to you have? If no one can send outbound, sounds like a mis-configuration or a DNS lookup issue.

    Can you run Get-SendConnector | fl and post the results? Looking for AddressSpaces, DNSRoutingEnabled, SmartHosts, SourceTransportServers, Enabled, port

     
  5. adns_jeremy

    adns_jeremy

    Guest
    Do you have a one-to-one NAT configured for your Exchange server that corresponds to the IP listed on your MX records? If so, check to make sure that your domain is not listed on any Real-time Black Lists (RBL's). You can check here: http://mxtoolbox.com/blacklists.aspx
     
  6. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Thanks all.

    No, there is no coexistence with any Exchange Server. I have up to 4 of them, yet nothing is happening.

    No one can send outbound mails.

    The Get-Send-Connector gives this:

    AddressSpaces : {SMTP:*;1}

    AuthenticationCredential :

    Comment :

    ConnectedDomains : {}

    ConnectionInactivityTimeOut : 00:10:00

    DNSRoutingEnabled : True

    DomainSecureEnabled : False

    Enabled : True

    ForceHELO : False

    Fqdn : mailserver.domain.com

    HomeMTA : Microsoft MTA

    HomeMtaServerId : mailserver

    Identity : OUTGOING INTERNET MAIL

    IgnoreSTARTTLS : False

    IsScopedConnector : False

    IsSmtpConnector : True

    LinkedReceiveConnector :

    MaxMessageSize : 10 MB (10,485,760 bytes)

    Name : OUTGOING INTERNET MAIL

    Port : 25

    ProtocolLoggingLevel : None

    RequireTLS : False

    SmartHostAuthMechanism : None

    SmartHosts : {}

    SmartHostsString :

    SmtpMaxMessagesPerConnection : 20

    SourceIPAddress : 0.0.0.0

    SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)

    SourceTransportServers : {mailserver}

    UseExternalDNSServersEnabled : False

    AddressSpaces : {SMTP:*;1}

    AuthenticationCredential :

    Comment :

    ConnectedDomains : {}

    ConnectionInactivityTimeOut : 00:10:00

    DNSRoutingEnabled : True

    DomainSecureEnabled : False

    Enabled : True

    ForceHELO : False

    Fqdn : mailserver.domain.com

    HomeMTA : Microsoft MTA

    HomeMtaServerId : mailserver

    Identity : Outgoing Internet Mails

    IgnoreSTARTTLS : False

    IsScopedConnector : False

    IsSmtpConnector : True

    LinkedReceiveConnector :

    MaxMessageSize : 10 MB (10,485,760 bytes)

    Name : Outgoing Internet Mails

    Port : 25

    ProtocolLoggingLevel : None

    RequireTLS : False

    SmartHostAuthMechanism : None

    SmartHosts : {}

    SmartHostsString :

    SmtpMaxMessagesPerConnection : 20

    SourceIPAddress : 0.0.0.0

    SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)

    SourceTransportServers : {mailserver}

    UseExternalDNSServersEnabled : True

    AddressSpaces : {SMTP:*;1}

    AuthenticationCredential :

    Comment :

    ConnectedDomains : {}

    ConnectionInactivityTimeOut : 00:10:00

    DNSRoutingEnabled : True

    DomainSecureEnabled : False

    Enabled : True

    ForceHELO : False

    Fqdn : mailserver.domain.com

    HomeMTA : Microsoft MTA

    HomeMtaServerId : mailserver

    Identity : L1

    IgnoreSTARTTLS : False

    IsScopedConnector : False

    IsSmtpConnector : True

    LinkedReceiveConnector :

    MaxMessageSize : 10 MB (10,485,760 bytes)

    Name : L1

    Port : 25

    ProtocolLoggingLevel : None

    RequireTLS : False

    SmartHostAuthMechanism : None

    SmartHosts : {}

    SmartHostsString :

    SmtpMaxMessagesPerConnection : 20

    SourceIPAddress : 0.0.0.0

    SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)

    SourceTransportServers : {mailserver}

    UseExternalDNSServersEnabled : True

    AddressSpaces : {smtp:*;1}

    AuthenticationCredential :

    Comment :

    ConnectedDomains : {}

    ConnectionInactivityTimeOut : 00:10:00

    DNSRoutingEnabled : True

    DomainSecureEnabled : False

    Enabled : True

    ForceHELO : False

    Fqdn : mailserver.domain.com

    HomeMTA : Microsoft MTA

    HomeMtaServerId : mailserver

    Identity : Internet

    IgnoreSTARTTLS : False

    IsScopedConnector : False

    IsSmtpConnector : True

    LinkedReceiveConnector :

    MaxMessageSize : 10 MB (10,485,760 bytes)

    Name : Internet

    Port : 25

    ProtocolLoggingLevel : None

    RequireTLS : False

    SmartHostAuthMechanism : None

    SmartHosts : {}

    SmartHostsString :

    SmtpMaxMessagesPerConnection : 20

    SourceIPAddress : 0.0.0.0

    SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)

    SourceTransportServers : {mailserver}

    UseExternalDNSServersEnabled : True

    I checked the MXTOOLBOX and it is not there.

    Note I used the Mail Flow Troublshooter and I had an issue like this:

    Mail submission failed: Error message: The SMTP host was not specified..

    Thanks
     
  7. TWHarrington

    TWHarrington

    Guest
    So you have 4 different Send connectors? This is your problem, they all have the same address space. If you have 4 HUB servers you can add all four HUB servers to the same send connector. Delete all of the send connectors except for one of them and add all HUB servers to use this connector.
     
  8. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    I have removed all except 1. I only have a single Hub.
     
  9. TWHarrington

    TWHarrington

    Guest
    ok good, so one send connector and one hub...restart the transport service. Does it work now?
     
  10. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Thanks. But It has not dropped into the External Recepient mailbox.

    I noticed the no. of messages in the Queue reduced and I had more Messages on the Message tab of the Queue Viewer.
     
  11. TWHarrington

    TWHarrington

    Guest
    Can you run the Get-SendConnector again. I see that you have UseExternalDNSServersEnabled = true. Do you have some defined. If you disable this, it will use your internal DNS servers. Unless there is a particular reason for using ExternDNS server, I would not check this box.
     
  12. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Ok...it shows:

    AddressSpaces : {smtp:*;1}

    AuthenticationCredential :

    Comment :

    ConnectedDomains : {}

    ConnectionInactivityTimeOut : 00:10:00

    DNSRoutingEnabled : True

    DomainSecureEnabled : False

    Enabled : True

    ForceHELO : False

    Fqdn : mail.domain.com

    HomeMTA : Microsoft MTA

    HomeMtaServerId : mail

    Identity : Internet

    IgnoreSTARTTLS : False

    IsScopedConnector : False

    IsSmtpConnector : True

    LinkedReceiveConnector :

    MaxMessageSize : 10 MB (10,485,760 bytes)

    Name : Internet

    Port : 25

    ProtocolLoggingLevel : None

    RequireTLS : False

    SmartHostAuthMechanism : None

    SmartHosts : {}

    SmartHostsString :

    SmtpMaxMessagesPerConnection : 20

    SourceIPAddress : 0.0.0.0

    SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)

    SourceTransportServers : {mail}

    UseExternalDNSServersEnabled : True

    Do you recommend I disable the External DNS?
     
  13. TWHarrington

    TWHarrington

    Guest
    Did you specifically tell it what External DNS servers to use? If not, then it will fail. Try disabling it and restarting the Transport service. Then see what happens.
     
  14. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    I am not sure I did, that, everything is default. How do I tell it which one to us?
     
  15. TWHarrington

    TWHarrington

    Guest
    See this link:

    http://technet.microsoft.com/en-us/library/aa997285.aspx

    Use the External DNS Lookup settings on the transport server Select this check box if you want to use a specific list of external DNS servers instead of the DNS servers configured on the network adapters of the source servers configured for this Send connector.

    Important: Verify that you have configured the external DNS servers list by using the Set-TransportServer cmdlet, or by using the External DNS Lookups tab in the properties of the Hub Transport server object or the Edge Transport server object.

     
  16. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Thanks. I tried it with no luck.

    I had to add 2 dns servers from our ISP.
     
  17. TWHarrington

    TWHarrington

    Guest
    So it works after adding the two external DNS servers from your ISP? IF you have External DNS enabled, you must have servers listed, if you don't have external servers in the list then you must not enable external DNS.

    Please let me know if you resolved your issue and it is working now.

     
  18. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    It did not work after the IP address was added. I still see the previous:

    451 4.4.0 Primary target IP address responded with: " 421 4.2.1 Unable to connect." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

    Should it be any thing with the MX records?
     
  19. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Also, I wish to note that I had created some email address policies ealier.

    We had a .biz domain and we used POP3 to pull all the emails to the .com domain.

    But on the Queue, I see the Outgoing email address as me@domain.biz instead of me@domain.com can this be part of the reason for the problem?
     
  20. Ifeatu Osegbo

    Ifeatu Osegbo

    Guest
    Hello,

    I figure out that outbound SMTP traffic is not allowed to leave my lan here.

    I can telnet to external smtp servers from outside our network, but I cannot do same from our network.

    I have called the ISP and they said they did not block it. I wil get to talk to the Cisco guys tomorrow.
     

Share This Page