1. Notice: I had to turn off email alerts for everyone. Anyone who wants email notification can re-enable the email alerts in their profile at outlookforums.com/account/preferences (and Alert Preferences). Also verify your email address is correct under Contact Details.

Outlook 2010, Multiple Accounts & Default Account

Discussion in 'Outlook and Exchange Polls' started by Diane Poremsky, Aug 18, 2010.

?

Do you like Outlook 2010's handling of default accounts?

  1. Yes, I use Outlook 2010 and I like this feature.

    7 vote(s)
    46.7%
  2. No, I use Outlook 2010 and don't like it. It's more work & I send mail from the wrong account.

    8 vote(s)
    53.3%
  3. I don't use Outlook 2010, but I think it sounds like a great feature.

    0 vote(s)
    0.0%
  4. I don't use Outlook 2010, but it doesn't sound like a feature I'd like.

    0 vote(s)
    0.0%
  5. Really? I use Outlook 2010 but didn't know it did that because I use one account or only one pst.

    0 vote(s)
    0.0%
  1. Diane Poremsky

    Diane Poremsky

    Senior Member
    Outlook 2010 has a nifty new feature or an annoying bug, depending on your point of view. The problem feature? The lack of a true default account when there are multiple accounts delivered to different pst files in the profile. Outlook uses the account assigned to the pst the folder is in for new messages, not the default account assigned in Account Settings.



    I like it. A lot of people don't. The ones who complain the most seem to be those with multiple accounts and IMAP accounts set as default. Because Calendar and Contacts are not stored in the IMAP pst, the account that is delivered to the pst holding the calendar and contacts is used for new messages created while view calendar and contacts.



    What do you think?
  2. Jonathan More

    Jonathan More

    Member
    I made the mistake of sending quite a few work related emails (imap) from my private address (pop), so thats why I started looking solution and found this poll. I think this new feature is nifty feature for some, but for me when I need to jump from account to account several times a day, its not.



    Is it so that if I would have only pop emails, it would use default sending account to all of those?
  3. Diane Poremsky

    Diane Poremsky

    Senior Member
    If you used pop accounts and all went into one pst, the default would work as in older versions. If theyeach had their own pst, it would vary with the selected folder.



    Did you see the registry fix to force acccount selection? That is one solution to the problem for IMAP users - and there is a macro that always uses the default set in Account settings.



    The reg key and links to the macro are here:: http://www.slipstick.com/emo/2010/up100826.htm#4
  4. Jonathan More

    Jonathan More

    Member
    Thanks for reply.



    I did the "Outlook 20010 Macro to use the Default Account" and it worked fine yesterday but today when I started Outlook, it doesn't work any more? Button is still there but nothing happen.



    I dont know anything about coding, but does "ThisOutlookSession" mean that the macro will only work untill I close the program?
  5. AdamV

    AdamV

    Member
    I use two Exchange accounts and 3 pop (from different providers).



    I like that new messages go from the account I am currently working on / thinking about based on the folder I am using, this makes perfect sense to me and I have not (knowingly) made a mistake yet in over a year of using this.

    This is possibly helped because I have very different signatures set up for the different accounts, so I guess that extra visual clue helps me.

    Maybe that's my tip to people who struggle with this: vary your signatures!



    My gut feel is that I less frequently have to choose a different "From" account now than if it did always use a default account when I hit Ctrl-Shift-M
  6. Forum Admin

    Forum Admin

    Administrator
    It sounds like macros are disabled. file, options, trust center - trust center settings - macro setting. Is it set to disable unsigned macros? (I use notify on all.)
  7. Forum Admin

    Forum Admin

    Administrator
    This is why they made the change. :)
  8. Jonathan More

    Jonathan More

    Member
    Thanks Slipstick, that worked!
  9. Per Ekstrom

    Per Ekstrom

    Member
    I have used outlook since early dawn ( well over 10 years). Had a love/hate relationship over the years and difficulty to find a better alternative.



    I also use to be a devoted fan of Slipstick hoping for things to get better and also developed and had staff doing forms and applications within outlook.



    No more.



    Outlook 2010 is an embarrassment.And a pain in the ass of any professional institution.



    You are gone.



    And you are wasting my time with such a ridiculousness blurry and slow application.



    Shame on you.



    // Per Ekstrom
  10. Per Ekstrom

    Per Ekstrom

    Member
    spellcheck...

    Sorry about the grammar in my last posting. But I hope you get it.

    We all deserve a way much better email/productivity app.



    If you don't like my post you are probably using msn, like 55% did 4 years ago...and 5% now.
  11. Diane Poremsky

    Diane Poremsky

    Senior Member
    What program replaced it? For all its warts (and it does have some), Outlook is the best mail/calendar/contact client around for businesses. Even Notes users perfer it... many smartphone users are stuck with it for syncing calendar and contacts...
  12. Chris Butler

    Chris Butler

    Member
    For the first time in many years (with a lot of help from Slipstick), this feature has me stumped.



    I have two account with two different ISPs. One is IMAP (me@imap.com), one is POP (me@pop.com). Neither ISP allows relaying of other ISP's mail.



    So ... Outlook 2010 always uses the POP account to send from and so I can't send me@imap.com e-mail at all !



    Am I missing something ?
  13. Forum Admin

    Forum Admin

    Administrator
    If you are viewing the imap folders when you send new mail, does it work?

    If you select the IMAP account in the account selector, does it work?

    In this case, you're hitting the new behavior - see http://www.slipstick.com/emo/2010/up100826.htm#4 for methods to work around this problem.

    Is the POP3 account the one provided by the ISP through whom you are connected to the Internet?

    If the IMAP account is selected as the send account but is mysteriously changed to the pop account, its usually the internet host doing it - many no longer allow access to port 25 on other networks and some will change the from address to the one acssociated with the account. Changing the outgoing port and authenticating with the server will fix this problem.
  14. Chris Butler

    Chris Butler

    Member
    Q: If you are viewing the imap folders when you send new mail, does it work?

    A: No, even if I select the IMAP account, the mail goes to the folder associated with the POP account and uses the POP account to send.



    Q: If you select the IMAP account in the account selector, does it work?

    A: No, same as above



    Q: In this case, you're hitting the new behavior ...

    A: I've tried the macro one, but not the registry one - but since Outlook always sends to the POP account no matter what I select, I don't see it working.



    Q: Is the POP3 account the one provided by the ISP through whom you are connected to the Internet?

    A: No, it's the IMAP account which is the 'home' account. The POP one is the one that works and is the 'foreign' account !!!



    By the way, the test send in the account set-up works just fine.



    I'm just baffled. It seems so simple to have two accounts and all worked fine in the previous Outlook versions.



    I've been reduced to sending e-mail through the POP account with the IMAP address as a reply-to which defeats the whole purpose of the IMAP account (having web access to my Outlook folders).
  15. Forum Admin

    Forum Admin

    Administrator
    Definitely baffling.

    Did you upgrade and keep a profile used in an older version? (If so, it should mostly work like before- and selecting the imap account as the from account should use it.)

    Did you try a new profile? I'd start with an imap only profile and see if it works ok. Then add the pop account and see if the behavior reverts. (Don't delete the first profile - just make a new one to test.)
  16. Chris Butler

    Chris Butler

    Member
    I started afresh and didn't convert.



    I've tried the new Profile as you suggested and offer below some comments on what seems to cause the problem.



    Previously, I think I set up the POP account first. This time I started with the IMAP account. When you set that up Outlook automatically creates a 'companion' pst to the IMAP-linked pst. Obviously that 'companion' pst has the default Contacts etc. in it, but it is also the account used to send mail through. I guess that makes sense since the sending is done though SMTP and not IMAP.



    When I set up the POP account, I created another (third) pst so that the pst used for the POP account and the pst used for the IMAP sending are separate. That seems to work.



    What still screws it up is if you move the IMAP pst. That seems to break the invisible link to the 'companion' pst and at that point sent e-mail goes to that pst but just sits in the Outbox. I did the move in the 'proper' way, so I guess that process just doesn't work for IMAP accounts in Outlook 2010 ?



    Net result is it works, but it does mean that I have two psts (I have two IMAP accounts, not just the one) that will grow and grow on my c: drive unless I clear out the trash regularly (having a very large trash box on a server was another attraction of IMAP for me).



    You can safely guess which way I'm voting in the poll !
  17. Diane Poremsky

    Diane Poremsky

    Senior Member


    You used this method? http://www.slipstick.com/config/moveimap.asp - i know it works for the bgasic maove in 2010, but i didn't test how it worked with the sending accounts. I guess i'll have to check it out.
  18. Chris Butler

    Chris Butler

    Member
    Yup. I followed your advice (as always :) ).



    I didn't try moving both the IMAP pst and the 'companion' pst so that they stay together. Perhaps that works.
  19. Diane Poremsky

    Diane Poremsky

    Senior Member
    i'll test it - oh, another thought - what sent folder were you using for sent items? That might need updated when a pst is moved.

    Account settings, double click account, more settings - sent tab.

    [​IMG]
  20. Chris Butler

    Chris Butler

    Member
    I used the default - made no changes. That is to say, the Sent Items folder in the IMAP pst (not in the 'companion' pst).



    Just to be clear, when I send items from the IMAP account, you see them in the Outbox on the 'companion' pst, but the sent item is in the Sent Items folder in the IMAP pst.

Share This Page

Powered by IISpeed - Google PageSpeed optimization for Microsoft IIS and ASP.NET