Email Address No Longer Valid

Discussion in 'Exchange Server Questions' started by DG1212, Oct 7, 2010.

  1. DG1212

    DG1212

    Guest
    I'm seeing an odd issue where when someone sends an email to an internal user on Exchange 2010, Outlook will tell them:

    This e-mail cannot be delivered to [user] because the email address is no longer valid.

    The email address is being pulled from the GAL and I know it is in fact a valid email address. This does not happen to all users, only a select hand full.
  2. AndyD_ [MVP]

    AndyD_ [MVP]

    Guest
    This is a mail tip right? Not a NDR?

    For those who are seeing these, check their local contacts or suggested contacts and remove the entry if there. Also, if they are getting this address via auto complete, delete the entry and pick it explicitly from the GAL.
  3. Frank.Wang

    Frank.Wang

    Guest
  4. Rajith Enchiparambil

    Rajith Enchiparambil

    Guest
    As suggested above, try picking the user from the GAL itself. No outlook autocomplete.

    If it still bounces, paste the error here.



    Rajith Enchiparambil | http://www.howexchangeworks.com |
  5. DG1212

    DG1212

    Guest
    Still having the issue. Is there a way to resolve this issue without having to clear the Outlook autocomplete cache on everyones Outlook client?

    Here is the description for the MailTip being displayed:

    Invalid recipient address

    Displayed when the recipient’s address is no longer valid – this can often happen if a recipient address was stored in the nickname cache but the recipient has left your organization since the last time it was used.

    The issue is that the user has not left my organization, they have only been moved from an Exchange 2003 server to an Exchange 2010 server. Why does Outlook/Exchange think the user is no longer there?
  6. Paul Voller

    Paul Voller

    Guest
    I was also experiencing this issue after a recent migration from Exchange 2003 to 2010 and managed to fix it by doing the following.

    The problem would occur when an Outlook 2010 user would add a recipient to an email who existed in both the GAL and their contacts folder (and/or their suggested contacts list too).

    I removed the company email address from their contact card stored in the contacts folder (no need to delete the whole contact, just their company email address), saved it, deleted any auto-complete/suggested contacts that could cause confusion, restarted Outlook and then created an email to the contact. This resolved the issue as Outlook 2010 was then taking just the contact from the GAL.

Share This Page

Powered by IISpeed - Google PageSpeed optimization for Microsoft IIS and ASP.NET